注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

itoedr的it学苑

记录从IT文盲学到专家的历程

 
 
 

日志

 
 

ubuntu1604版本上安装ffidiaporama的简易方法  

2016-09-09 10:48:20|  分类: linux产品 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
          ubuntu1604版本只提供了ffdiaporama1.5的版本,在加载音乐时总是出错,但ffdiaporama2.1却很好地处理了这个问题。但是新的问题也来了,作者只是给出了ubuntu1404的优化版本,自ubuntu1604出版以来,却一直没有给更新版本。而在源码安装时又出现太多依赖不足,更主要的是,ffdiaporama比openshot、kdenlive都有好用的地方,做好视频更为专业,当然一blender这种开源3d动画软件结合使用,做一部大片也同样在行。
          下面记录一下ubuntu1604版本上的安装过程,主要是几个关键点。
           1、加入ffdiaporama的软件源索引
            还有,作者很友好地将ffdiaporama各个版本都放到了ubuntu的开源资源社区Launchpad上了,使用
“sudo add-apt-repository ppa:ffdiaporamateam/stable”命令即可将软件索引加入到本地软件库。
ubuntu1604版本上安装ffidiaporama的简易方法 - itoedr - itoedr的it学苑
图1 在launchpad上的ffdiaporama的软件源版本
 ubuntu1604版本上安装ffidiaporama的简易方法 - itoedr - itoedr的it学苑
图2 ffdiaporama源站对ffdiaporama软件的介绍 

          但是,“add-apt-repository”命令是自动取系统版本为本地软件库配置软件索引的,比如使用以上命令后,要source.list清单里增加的是1604的版本,但在Launchpad里却没有这个版本,因此还得手修正。
         
ubuntu1604版本上安装ffidiaporama的简易方法 - itoedr - itoedr的it学苑
图3 在发行版那改为trusty(对应1404版本)
现在按照提示进行更新,在本地软件库即可读到ffdiaporama2.1的软件了。但是还有两个问题需要确定。
       1是保证ffdiaporama的老版本先得清理干净: 也许是升级版本太快,ubuntu本身会把ffdiaporama2.1当作一个新软件来对待,却又共享一些系统资源锁,因此在安装过程中出现了报错现象。
        2是解决ffdiaporama2.1的依赖库问题: 也许因为ffdiaporama2.1目前只是为ubuntu1404版本打的包,很多依存库还是ubuntu1404上的版本,所以还要引入ubuntu1404的官方软件源,比如:
      "deb http://mirrors.163.com/ubuntu/ trusty main restricted universe multiverse"
ubuntu1604版本上安装ffidiaporama的简易方法 - itoedr - itoedr的it学苑
图4 修正软件源的情况
 
      接下来进行软件库更新,即可安装成功.
 
ubuntu1604版本上安装ffidiaporama的简易方法 - itoedr - itoedr的it学苑
图5 最后安装情况
ubuntu1604版本上安装ffidiaporama的简易方法 - itoedr - itoedr的it学苑
2.1版本的ffdiaporama可以上线了
 
  评论这张
 
阅读(30)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017